package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^.]*)\.([^.]*)$`)
var str = `cc-api-data.bar.bar
external-atl3-1.xx.fbcdn.net
fbcdn.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}