$re = '/([^.]*)\.([^.]*)$/m';
$str = 'cc-api-data.bar.bar
external-atl3-1.xx.fbcdn.net
fbcdn.net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);