re = /([^.]*)\.([^.]*)$/m
str = 'cc-api-data.bar.bar
external-atl3-1.xx.fbcdn.net
fbcdn.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end