const regex = new RegExp('^(?:.*) (?:access-group)(.*)(?:in)(?:\\n)(?:.*)(?:access-group)(.*)(?:out)', 'gm')
const str = `interface Vlan100
description NAME
ip address 10.0.0.1 255.255.255.0
ip helper-address 111.111.1.1
ip access-group IN_ACL in
ip access-group OUT_ACL out`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}