import Foundation
let pattern = #"^(?:.*) (?:access-group)(.*)(?:in)(?:\n)(?:.*)(?:access-group)(.*)(?:out)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
interface Vlan100
description NAME
ip address 10.0.0.1 255.255.255.0
ip helper-address 111.111.1.1
ip access-group IN_ACL in
ip access-group OUT_ACL out
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)