$re = '/SITE "(?=([^"]+))/m';
$str = 'SITE "test_website--production" (id:1207042133,bindings:http/127.0.0.1:9900:,state:Started)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);