const regex = /(?<=symbol\=)[\w\d-]+(?=&|\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=symbol\\=)[\\w\\d-]+(?=&|\\n)', 'g')
const str = `https://www.set.or.th/set/companyholder.do?symbol=EMC
https://www.set.or.th/set/companyholder.do?symbol=EMC&language=th&country=TH
https://www.set.or.th/set/companyholder.do%3Bjsessionid=B08A576398DF62A466D1D08EAAF280CC?symbol=BLAND-F&language=en&country=EN
https://www.set.or.th/set/newsdetails.do?newsId=14828768298911&language=th&country=TH
https://www.set.or.th/set/companyholder.do?symbol=RML-F&ssoPageId=6&language=th&country=TH`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}