re = /(?<=symbol\=)[\w\d-]+(?=&|\n)/
str = 'https://www.set.or.th/set/companyholder.do?symbol=EMC
https://www.set.or.th/set/companyholder.do?symbol=EMC&language=th&country=TH
https://www.set.or.th/set/companyholder.do%3Bjsessionid=B08A576398DF62A466D1D08EAAF280CC?symbol=BLAND-F&language=en&country=EN
https://www.set.or.th/set/newsdetails.do?newsId=14828768298911&language=th&country=TH
https://www.set.or.th/set/companyholder.do?symbol=RML-F&ssoPageId=6&language=th&country=TH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end