import re
regex = re.compile(r"(?<=symbol\=)[\w\d-]+(?=&|\n)")
test_str = ("https://www.set.or.th/set/companyholder.do?symbol=EMC\n"
"https://www.set.or.th/set/companyholder.do?symbol=EMC&language=th&country=TH\n"
"https://www.set.or.th/set/companyholder.do%3Bjsessionid=B08A576398DF62A466D1D08EAAF280CC?symbol=BLAND-F&language=en&country=EN\n"
"https://www.set.or.th/set/newsdetails.do?newsId=14828768298911&language=th&country=TH\n"
"https://www.set.or.th/set/companyholder.do?symbol=RML-F&ssoPageId=6&language=th&country=TH")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")