using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"c\.CreateMap<([\w.])+,\s+[\w.]*Address>";
string input = @"c.CreateMap<ClientAddress, Address>()
c.CreateMap<Responses.SiteAddress, Data.Address>()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}