re = /c\.CreateMap<([\w.])+,\s+[\w.]*Address>/m
str = 'c.CreateMap<ClientAddress, Address>()
c.CreateMap<Responses.SiteAddress, Data.Address>()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end