$re = '/c\.CreateMap<([\w.])+,\s+[\w.]*Address>/m';
$str = 'c.CreateMap<ClientAddress, Address>()
c.CreateMap<Responses.SiteAddress, Data.Address>()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);