package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[Dd][Uu]-{0,1}[Ee]\s*:{0,1}\s*\d{2}BR\d{9}-{0,1}\d{1}`)
var str = `DUe23BR0000409942`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}