re = /[Dd][Uu]-{0,1}[Ee]\s*:{0,1}\s*\d{2}BR\d{9}-{0,1}\d{1}/m
str = 'DUe23BR0000409942'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end