import re
regex = re.compile(r"[Dd][Uu]-{0,1}[Ee]\s*:{0,1}\s*\d{2}BR\d{9}-{0,1}\d{1}", flags=re.MULTILINE)
test_str = "DUe23BR0000409942"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")