#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=attn\s)(?:[0-9]{1,2}|1[01][0-9]|12[0-8])$"
Local $sString = "_4ÑZŸs_4ÑZâ7o[?1034h" & @CRLF & _
"_4ÑZ8obash-3.2$ e4ÑZ”C" & @CRLF & _
"i[A e4ÑZõD" & @CRLF & _
"oscript -re4ÑZˇ?" & @CRLF & _
"i[Ae4ÑZ∑@" & @CRLF & _
"opython go.pyf4ÑZÌ" & @CRLF & _
"i" & @CRLF & _
"f4ÑZ£Ì" & @CRLF & _
"o" & @CRLF & _
"f4ÑZÊÚoattn 0" & @CRLF & _
"f4ÑZ,Ûoattn 0" & @CRLF & _
"attn 0" & @CRLF & _
"Hf4ÑZuÛoattn 99" & @CRLF & _
"attn 100" & @CRLF & _
"attn 0" & @CRLF & _
"attn 0" & @CRLF & _
"attn 0" & @CRLF & _
"attn 128" & @CRLF & _
"attn 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")