re = /(?<=attn\s)(?:[0-9]{1,2}|1[01][0-9]|12[0-8])$/m
str = '_4ÑZŸs_4ÑZâ7o[?1034h
_4ÑZ8obash-3.2$ e4ÑZ”C
i[A e4ÑZõD
oscript -re4ÑZˇ?
i[Ae4ÑZ∑@
opython go.pyf4ÑZÌ
i
f4ÑZ£Ì
o
f4ÑZÊÚoattn 0
f4ÑZ,Ûoattn 0
attn 0
Hf4ÑZuÛoattn 99
attn 100
attn 0
attn 0
attn 0
attn 128
attn 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end