const regex = /(?<=attn\s)(?:[0-9]{1,2}|1[01][0-9]|12[0-8])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=attn\\s)(?:[0-9]{1,2}|1[01][0-9]|12[0-8])$', 'gm')
const str = `_4ÑZŸs_4ÑZâ7o[?1034h
_4ÑZ8obash-3.2\$ e4ÑZ”C
i[A e4ÑZõD
oscript -re4ÑZˇ?
i[Ae4ÑZ∑@
opython go.pyf4ÑZÌ
i
f4ÑZ£Ì
o
f4ÑZÊÚoattn 0
f4ÑZ,Ûoattn 0
attn 0
Hf4ÑZuÛoattn 99
attn 100
attn 0
attn 0
attn 0
attn 128
attn 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}