#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?# Date )" & @CRLF & _
" (?# Day ranges )" & @CRLF & _
" (?<d_day28>0[1-9]|1\d|2[0-8]|[1-9])" & @CRLF & _
" (?<d_day29>0[1-9]|1\d|2\d|[1-9])" & @CRLF & _
" (?<d_day30>0[1-9]|1\d|2\d|30|[1-9])" & @CRLF & _
" (?<d_day31>0[1-9]|1\d|2\d|3[01]|[1-9])" & @CRLF & _
" (?# Month specifications )" & @CRLF & _
" (?<d_month28>0?2)" & @CRLF & _
" (?<d_month29>0?2)" & @CRLF & _
" (?<d_month30>0?[469]|11)" & @CRLF & _
" (?<d_month31>0?[13578]|1[02])" & @CRLF & _
" (?# Year specifications )" & @CRLF & _
" (?<d_year>\d+)" & @CRLF & _
" (?<d_yearLeap>(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))" & @CRLF & _
" (?# Valid date formats )" & @CRLF & _
" (?<d_format>" & @CRLF & _
" (?&d_day28)-(?&d_month28)-(?&d_year)|" & @CRLF & _
" (?&d_day29)-(?&d_month29)-(?&d_yearLeap)|" & @CRLF & _
" (?&d_day30)-(?&d_month30)-(?&d_year)|" & @CRLF & _
" (?&d_day31)-(?&d_month31)-(?&d_year)" & @CRLF & _
" )" & @CRLF & _
")" & @CRLF & _
"\b(?&d_format)\b"
Local $sString = "29-02-2016 - valid" & @CRLF & _
"29-02-2017 - invalid (not leap year)" & @CRLF & _
"30-03-2016 - valid" & @CRLF & _
"29-2-2017 - invalid (not leap year)" & @CRLF & _
"28-2-2017 - valid" & @CRLF & _
"2-2-2017 - valid" & @CRLF & _
"31-11-2017 - invalid (November has 30 days)" & @CRLF & _
"30-11-2017 - valid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")