import re
regex = re.compile(r"""
(?(DEFINE)
(?# Date )
(?# Day ranges )
(?<d_day28>0[1-9]|1\d|2[0-8]|[1-9])
(?<d_day29>0[1-9]|1\d|2\d|[1-9])
(?<d_day30>0[1-9]|1\d|2\d|30|[1-9])
(?<d_day31>0[1-9]|1\d|2\d|3[01]|[1-9])
(?# Month specifications )
(?<d_month28>0?2)
(?<d_month29>0?2)
(?<d_month30>0?[469]|11)
(?<d_month31>0?[13578]|1[02])
(?# Year specifications )
(?<d_year>\d+)
(?<d_yearLeap>(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))
(?# Valid date formats )
(?<d_format>
(?&d_day28)-(?&d_month28)-(?&d_year)|
(?&d_day29)-(?&d_month29)-(?&d_yearLeap)|
(?&d_day30)-(?&d_month30)-(?&d_year)|
(?&d_day31)-(?&d_month31)-(?&d_year)
)
)
\b(?&d_format)\b
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("29-02-2016 - valid\n"
"29-02-2017 - invalid (not leap year)\n"
"30-03-2016 - valid\n"
"29-2-2017 - invalid (not leap year)\n"
"28-2-2017 - valid\n"
"2-2-2017 - valid\n"
"31-11-2017 - invalid (November has 30 days)\n"
"30-11-2017 - valid")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")