// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?(DEFINE)
(?# Date )
(?# Day ranges )
(?<d_day28>0[1-9]|1\d|2[0-8]|[1-9])
(?<d_day29>0[1-9]|1\d|2\d|[1-9])
(?<d_day30>0[1-9]|1\d|2\d|30|[1-9])
(?<d_day31>0[1-9]|1\d|2\d|3[01]|[1-9])
(?# Month specifications )
(?<d_month28>0?2)
(?<d_month29>0?2)
(?<d_month30>0?[469]|11)
(?<d_month31>0?[13578]|1[02])
(?# Year specifications )
(?<d_year>\d+)
(?<d_yearLeap>(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))
(?# Valid date formats )
(?<d_format>
(?&d_day28)-(?&d_month28)-(?&d_year)|
(?&d_day29)-(?&d_month29)-(?&d_yearLeap)|
(?&d_day30)-(?&d_month30)-(?&d_year)|
(?&d_day31)-(?&d_month31)-(?&d_year)
)
)
\b(?&d_format)\b").unwrap();
let string = "29-02-2016 - valid
29-02-2017 - invalid (not leap year)
30-03-2016 - valid
29-2-2017 - invalid (not leap year)
28-2-2017 - valid
2-2-2017 - valid
31-11-2017 - invalid (November has 30 days)
30-11-2017 - valid";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}