using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"зак[А-Яа-я]+";
string input = @"Шурыгина может закрыть тебя на 8 лет";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}