#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[\/])[^\/?=]+(?=\/?$|\/?\?)"
Local $sString = "https://test.com/welcome/" & @CRLF & _
"https://sub.test.com/home/edit" & @CRLF & _
"https://test.com/home/view?view=column" & @CRLF & _
"https://test.com/home/view/?view=list" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")