re = /(?<=[\/])[^\/?=]+(?=\/?$|\/?\?)/m
str = 'https://test.com/welcome/
https://sub.test.com/home/edit
https://test.com/home/view?view=column
https://test.com/home/view/?view=list
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end