$re = '/(?<=[\/])[^\/?=]+(?=\/?$|\/?\?)/m';
$str = 'https://test.com/welcome/
https://sub.test.com/home/edit
https://test.com/home/view?view=column
https://test.com/home/view/?view=list
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);