#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?musi)\b(?:UG \(haftungsbeschränkt\)|(?:gG|g|Gesellschaft )?mbH|GbR|OHG|[KUeA]G|(?:g|Inv)AG|KGaA|e..?v..?|Limited|Stiftung|PartG(?: mbB)?|Partenreederei|Eigenbetrieb|Einzelunternehmen|Regiebetrieb|VVaG|SC?E|[AK]öR|Reit-AG)\s*(?:\&\s*Co.\s*(?:KGa?A?|OHG))?\b"
Local $sString = "Unternehmen Regex GbR" & @CRLF & _
"Unternehmen Regex KG" & @CRLF & _
"Unternehmen Regex AG & Co. KG" & @CRLF & _
"Unternehmen Regex GmbH & Co. KG" & @CRLF & _
"Unternehmen Regex Limited & Co. KG" & @CRLF & _
"Unternehmen Regex Stiftung & Co. KG" & @CRLF & _
"Unternehmen Regex Stiftung GmbH & Co. KG" & @CRLF & _
"Unternehmen Regex UG (haftungsbeschränkt) & Co. KG" & @CRLF & _
"Unternehmen Regex OHG" & @CRLF & _
"Unternehmen Regex GmbH & Co. OHG" & @CRLF & _
"Unternehmen Regex AG & Co. OHG" & @CRLF & _
"Unternehmen Regex Partenreederei" & @CRLF & _
"Unternehmen Regex PartG" & @CRLF & _
"Unternehmen Regex PartG mbB" & @CRLF & _
"Unternehmen Regex AG" & @CRLF & _
"Unternehmen Regex gAG" & @CRLF & _
"Unternehmen Regex GmbH" & @CRLF & _
"Unternehmen Regex gGmbH" & @CRLF & _
"Unternehmen Regex InvAG" & @CRLF & _
"Unternehmen Regex KGaA" & @CRLF & _
"Unternehmen Regex AG & Co. KGaA" & @CRLF & _
"Unternehmen Regex SE & Co. KGaA" & @CRLF & _
"Unternehmen Regex GmbH & Co. KGaA" & @CRLF & _
"Unternehmen Regex Stiftung & Co. KGaA" & @CRLF & _
"Unternehmen Regex REIT-AG" & @CRLF & _
"Unternehmen Regex UG (haftungsbeschränkt)" & @CRLF & _
"Unternehmen Regex AöR" & @CRLF & _
"Unternehmen Regex eG" & @CRLF & _
"Unternehmen Regex Eigenbetrieb" & @CRLF & _
"Unternehmen Regex Einzelunternehmen" & @CRLF & _
"Unternehmen Regex e. V." & @CRLF & _
"Unternehmen Regex KöR" & @CRLF & _
"Unternehmen Regex Regiebetrieb" & @CRLF & _
"Unternehmen Regex Stiftung" & @CRLF & _
"Unternehmen Regex VVaG" & @CRLF & _
"Unternehmen Regex EWIV" & @CRLF & _
"Unternehmen Regex SE" & @CRLF & _
"Unternehmen Regex SCE" & @CRLF & _
"Unternehmen Regex Gesellschaft mbH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")