import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"\b(?:UG \(haftungsbeschränkt\)|(?:gG|g|Gesellschaft )?mbH|GbR|OHG|[KUeA]G|(?:g|Inv)AG|KGaA|e..?v..?|Limited|Stiftung|PartG(?: mbB)?|Partenreederei|Eigenbetrieb|Einzelunternehmen|Regiebetrieb|VVaG|SC?E|[AK]öR|Reit-AG)\s*(?:\&\s*Co.\s*(?:KGa?A?|OHG))?\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
Unternehmen Regex GbR
Unternehmen Regex KG
Unternehmen Regex AG & Co. KG
Unternehmen Regex GmbH & Co. KG
Unternehmen Regex Limited & Co. KG
Unternehmen Regex Stiftung & Co. KG
Unternehmen Regex Stiftung GmbH & Co. KG
Unternehmen Regex UG (haftungsbeschränkt) & Co. KG
Unternehmen Regex OHG
Unternehmen Regex GmbH & Co. OHG
Unternehmen Regex AG & Co. OHG
Unternehmen Regex Partenreederei
Unternehmen Regex PartG
Unternehmen Regex PartG mbB
Unternehmen Regex AG
Unternehmen Regex gAG
Unternehmen Regex GmbH
Unternehmen Regex gGmbH
Unternehmen Regex InvAG
Unternehmen Regex KGaA
Unternehmen Regex AG & Co. KGaA
Unternehmen Regex SE & Co. KGaA
Unternehmen Regex GmbH & Co. KGaA
Unternehmen Regex Stiftung & Co. KGaA
Unternehmen Regex REIT-AG
Unternehmen Regex UG (haftungsbeschränkt)
Unternehmen Regex AöR
Unternehmen Regex eG
Unternehmen Regex Eigenbetrieb
Unternehmen Regex Einzelunternehmen
Unternehmen Regex e. V.
Unternehmen Regex KöR
Unternehmen Regex Regiebetrieb
Unternehmen Regex Stiftung
Unternehmen Regex VVaG
Unternehmen Regex EWIV
Unternehmen Regex SE
Unternehmen Regex SCE
Unternehmen Regex Gesellschaft mbH
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)