re = /\b(?:UG \(haftungsbeschränkt\)|(?:gG|g|Gesellschaft )?mbH|GbR|OHG|[KUeA]G|(?:g|Inv)AG|KGaA|e..?v..?|Limited|Stiftung|PartG(?: mbB)?|Partenreederei|Eigenbetrieb|Einzelunternehmen|Regiebetrieb|VVaG|SC?E|[AK]öR|Reit-AG)\s*(?:\&\s*Co.\s*(?:KGa?A?|OHG))?\b/mi
str = 'Unternehmen Regex GbR
Unternehmen Regex KG
Unternehmen Regex AG & Co. KG
Unternehmen Regex GmbH & Co. KG
Unternehmen Regex Limited & Co. KG
Unternehmen Regex Stiftung & Co. KG
Unternehmen Regex Stiftung GmbH & Co. KG
Unternehmen Regex UG (haftungsbeschränkt) & Co. KG
Unternehmen Regex OHG
Unternehmen Regex GmbH & Co. OHG
Unternehmen Regex AG & Co. OHG
Unternehmen Regex Partenreederei
Unternehmen Regex PartG
Unternehmen Regex PartG mbB
Unternehmen Regex AG
Unternehmen Regex gAG
Unternehmen Regex GmbH
Unternehmen Regex gGmbH
Unternehmen Regex InvAG
Unternehmen Regex KGaA
Unternehmen Regex AG & Co. KGaA
Unternehmen Regex SE & Co. KGaA
Unternehmen Regex GmbH & Co. KGaA
Unternehmen Regex Stiftung & Co. KGaA
Unternehmen Regex REIT-AG
Unternehmen Regex UG (haftungsbeschränkt)
Unternehmen Regex AöR
Unternehmen Regex eG
Unternehmen Regex Eigenbetrieb
Unternehmen Regex Einzelunternehmen
Unternehmen Regex e. V.
Unternehmen Regex KöR
Unternehmen Regex Regiebetrieb
Unternehmen Regex Stiftung
Unternehmen Regex VVaG
Unternehmen Regex EWIV
Unternehmen Regex SE
Unternehmen Regex SCE
Unternehmen Regex Gesellschaft mbH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end