using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Za-z0-9 ]+(?:-[A-Za-z0-9 ]+)?(. )?)*$";
string input = @"this - abc is . dsgsdgf -this is a- test
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}