re = /^([A-Za-z0-9 ]+(?:-[A-Za-z0-9 ]+)?(. )?)*$/
str = 'this - abc is . dsgsdgf -this is a- test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end