package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-Za-z0-9 ]+(?:-[A-Za-z0-9 ]+)?(. )?)*$`)
var str = `this - abc is . dsgsdgf -this is a- test
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}