package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<name>[^,]+),(?<score>[^%]+)`)
var str = `Arthur Albert,74%
Melissa Hay,72%
William Jones,85%
Rachel Lee,68%
Joshua Planner,75%
Jennifer Ranger,76%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}