re = /^(?<name>[^,]+),(?<score>[^%]+)/m
str = 'Arthur Albert,74%
Melissa Hay,72%
William Jones,85%
Rachel Lee,68%
Joshua Planner,75%
Jennifer Ranger,76%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end