import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<name>[^,]+),(?<score>[^%]+)";
final String string = "Arthur Albert,74% \n"
+ "Melissa Hay,72%\n"
+ "William Jones,85%\n"
+ "Rachel Lee,68%\n"
+ "Joshua Planner,75%\n"
+ "Jennifer Ranger,76%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}