using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'chemin'(?|(^)|(.*\\)|(.*\/)|(^\/)))(?'fichier'(?'prefix'[a-z0-9_\-]{4})(?'num_photo'[0-9]{1,10})(?'extention'\.[a-z0-9]{3,4}))$";
string input = @"/user/dd/MH105670.JPG";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}