use strict;
my $str = '/user/dd/MH105670.JPG';
my $regex = qr/(?'chemin'(?|(^)|(.*\\)|(.*\/)|(^\/)))(?'fichier'(?'prefix'[a-z0-9_\-]{4})(?'num_photo'[0-9]{1,10})(?'extention'\.[a-z0-9]{3,4}))$/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}