import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'chemin'(?|(^)|(.*\\\\)|(.*\\/)|(^\\/)))(?'fichier'(?'prefix'[a-z0-9_\\-]{4})(?'num_photo'[0-9]{1,10})(?'extention'\\.[a-z0-9]{3,4}))$";
final String string = "/user/dd/MH105670.JPG";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}