import Foundation
let pattern = #"NF.*?(\d*)\|.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
NF3-9-16S_S9_1456|M02255:210:000000000-B9K3P:1:1101:14397:18152 1:N:0:9|o:50|m/o:0.720000|MR:n=0;r1=34;r2=2|Q30:p=97;p=100|CO:0|mismatches:36
NF3-9-16S_S9_9999|M02255:210:000000000-B9K3P:1:1101:14397:18152 1:N:0:9|o:50|m/o:0.720000|MR:n=0;r1=34;r2=2|Q30:p=97;p=100|CO:0|mismatches:36
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Re1_91910_$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)