#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<name>([^<]*?)<\/name>"
Local $sString = "<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">" & @CRLF & _
" <env:Header/>" & @CRLF & _
" <env:Body>" & @CRLF & _
" <ns2:getListsInfoResponse xmlns:ns2="http://service.admin.ws.five9.com/">" & @CRLF & _
" <return>" & @CRLF & _
" <name>QuotaView</name>" & @CRLF & _
" <size>4</size>" & @CRLF & _
" </return>" & @CRLF & _
" </ns2:getListsInfoResponse>" & @CRLF & _
" </env:Body>" & @CRLF & _
"</env:Envelope>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")