use strict;
my $str = '<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">
<env:Header/>
<env:Body>
<ns2:getListsInfoResponse xmlns:ns2="http://service.admin.ws.five9.com/">
<return>
<name>QuotaView</name>
<size>4</size>
</return>
</ns2:getListsInfoResponse>
</env:Body>
</env:Envelope>';
my $regex = qr/<name>([^<]*?)<\/name>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}