package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{11}-[0-9]$`)
var str = `01422756860-8
1422756860-2
01422756860-99
11422756860-0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}