re = /^[0-9]{11}-[0-9]$/m
str = '01422756860-8
1422756860-2
01422756860-99
11422756860-0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end