$re = '/^[0-9]{11}-[0-9]$/m';
$str = '01422756860-8
1422756860-2
01422756860-99
11422756860-0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);