import re
regex = re.compile(r"C\DO")
test_str = ("Chief Compliance Officer (CCO)\n"
"Chief Security Officer (CSO)\n"
"Chief Green Officer (CGO)\n"
"Chief Analytics Officer (CAO)\n"
"Chief Marketing Officer (CMO)\n"
"Chief Data Officer (CDO)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")