re = /C\DO/
str = 'Chief Compliance Officer (CCO)
Chief Security Officer (CSO)
Chief Green Officer (CGO)
Chief Analytics Officer (CAO)
Chief Marketing Officer (CMO)
Chief Data Officer (CDO)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end