#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?x)(\w+\(" & @CRLF & _
" \?*\w+" & @CRLF & _
" (?:,\?*\w+)?" & @CRLF & _
" \)" & @CRLF & _
")" & @CRLF & _
"(," & @CRLF & _
" \w+\(" & @CRLF & _
" \?*\w+" & @CRLF & _
" (?:,\?*\w+)?" & @CRLF & _
" \)" & @CRLF & _
")*"
Local $sString = "a(b)" & @CRLF & _
"a(?v)" & @CRLF & _
"a(b),c(?c,a)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)