import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+\\(\n"
+ " \\?*\\w+\n"
+ " (?:,\\?*\\w+)?\n"
+ " \\)\n"
+ ")\n"
+ "(,\n"
+ " \\w+\\(\n"
+ " \\?*\\w+\n"
+ " (?:,\\?*\\w+)?\n"
+ " \\)\n"
+ ")*";
final String string = "a(b)\n"
+ "a(?v)\n"
+ "a(b),c(?c,a)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}