$re = '/(\w+\(
\?*\w+
(?:,\?*\w+)?
\)
)
(,
\w+\(
\?*\w+
(?:,\?*\w+)?
\)
)*/x';
$str = 'a(b)
a(?v)
a(b),c(?c,a)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;