package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[\b(dai|da)\b(\h{0,2}|:{1})][\d{1,2}][(\h{1}\b(anni|a|ai)\b\h{0,1}][(\d{1,2})]?`)
var str = `da 5 anni
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}