use strict;
my $str = 'da 5 anni
';
my $regex = qr/[\b(dai|da)\b(\h{0,2}|:{1})][\d{1,2}][(\h{1}\b(anni|a|ai)\b\h{0,1}][(\d{1,2})]?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}